[lkml]   [2001]   [Jun]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
Subjectisc_time_now Fatal Error

I've sent the following to the Bind9-Users list. It appears that this is a
kernel-related bug and they suggested I post it here as well.

I'm running Linux 2.4.5 and Bind 9.1.2 on a PowerPC. The same error has
popped up under 2.4.3 as well.

Please CC me with any responses as I'm not yet subscribed to this list.
Thanks in advance for any suggestions.

Clinton Hogge
Industrial Images

Original message:
Named (9.1.2) failed at about 3 this morning (it seems that's always the
time for problems :) with:

timer.c:646: fatal error:
RUNTIME_CHECK(isc_time_now(&now) == 0) failed
exiting (due to fatal error in library)

I saw one other post in the Bind9 archives regarding the same error.

Mark Andrews responded:

>The error message indicated isc_time_now() failed. Now
>isc_time_now() can fail for a number of reasons, the most
>likely one is that gettimeofday() returned a time with
>tv_usec out of range. i.e. you detected a kernel bug.
>This can often be fixed by the following.
>sysctl -w kern.timecounter.method=1

The only problem is that the original poster is running FreeBSD
3.3-RELEASE. My boxes are Power PCs running Linux 2.4.5 - sysctl reports
the above fix as an "unknown key."

Is there an equivalent fix for Linux?

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 12:54    [W:0.084 / U:0.584 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site