lkml.org 
[lkml]   [2001]   [Jun]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectTwo nfsd bugs in 2.4.x
Hi,

Since I switched to the kernel nfsd I have troubles exporting my
filesystems. I think in kernel 2.2.x there was no problem, neither was
it with the userspace nfsd. Currently I run kernel 2.4.5pre1 on the
server.

1. When I try to boot one of my diskless clients (kernel 2.0.34), it mounts
its root fs from /opt/boot/client which is on an ext2 fs. But apparently
it hangs when it tries to access lib/ld-linux.so.1 (seen with a network
sniffer). This is a symbolic link pointing to lib/ld-linux.so.1.9.2.
In the kernel log I find:

nfsd Security: lib/ld-linux.so.1 bad export.

2. I cannot any longer mount the server's /usr on certain workstations.
It works on my main workstation which currently runs kernel 2.4.5.
On other workstations I get "permission denied by server". I tried various
kernels (2.0.36, 2.2.3, 2.3.52) and various versions of mount (2.7l, 2.10o).
My /etc/exports contains the line

/usr *.hjb.de(rw,no_root_squash)

and all my clients are in my local DNS. The syslog shows

rpc.mountd: getfh failed: Operation not permitted

Any help? More info on request.

Thanks,
hjb
--
Pro-Linux - Germany's largest volunteer Linux support site
http://www.pro-linux.de/
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:55    [W:0.046 / U:0.064 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site