[lkml]   [2001]   [Jun]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: Two nfsd bugs in 2.4.x
    >Since I switched to the kernel nfsd I have troubles exporting my
    >filesystems. I think in kernel 2.2.x there was no problem, neither was
    >it with the userspace nfsd. Currently I run kernel 2.4.5pre1 on the

    i have also had a few problems with nfsd when i have
    moved to 2.4.x (2.4.5-ac15 currently) from 2.2.x
    both the server and client side.

    problems i have been seeing include.

    a) if the server goes down the client sometimes does not remount the
    share. and it prints lots of "stale nfs handles or something"
    this is fine if it is remounted by hand.

    >1. When I try to boot one of my diskless clients (kernel 2.0.34), it mounts
    >its root fs from /opt/boot/client which is on an ext2 fs. But apparently
    >it hangs when it tries to access lib/ (seen with a network
    >sniffer). This is a symbolic link pointing to lib/
    >In the kernel log I find:
    >nfsd Security: lib/ bad export.

    there are some options that do things with symlinks have you tried
    looking at some of those ?

    >2. I cannot any longer mount the server's /usr on certain workstations.
    >It works on my main workstation which currently runs kernel 2.4.5.
    >On other workstations I get "permission denied by server". I tried various
    >kernels (2.0.36, 2.2.3, 2.3.52) and various versions of mount (2.7l, 2.10o).
    >My /etc/exports contains the line
    >/usr *,no_root_squash)
    >and all my clients are in my local DNS. The syslog shows
    >rpc.mountd: getfh failed: Operation not permitted

    hi yes i saw this it appeard to rpc.mountd that the
    client had already mounted the dir but the nfsd
    seemed to think otherwise it was returning the
    error to rpc.mountd rebooting the server was the only
    work around i found in this restarting the programs
    did not seem to help.

    client1: mount /home (works fine)
    client2: mount /home (did not work)
    server: restart nfs programs
    client2: mount /home (did not work)
    server: reboot
    client2: mount /home (works)

    and client1 works all the way though (except when the
    server is down of course)

    i have only seem these a few times and its been working fine
    since. so i think they are probably pritty hard to produce

    Mobile: +44 07779080838
    11:20pm up 3:32, 5 users, load average: 0.33, 0.39, 0.33
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 12:55    [W:0.026 / U:1.624 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site