lkml.org 
[lkml]   [2001]   [Jun]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: Newbie idiotic questions.
Date
On Sunday 17 June 2001 21:18, Geert Uytterhoeven wrote:
> On Sun, 17 Jun 2001, Jeff Garzik wrote:
> > David Flynn wrote:
> > > > Daniel Phillips wrote:
> > > > > - if ((card->mpuout = kmalloc(sizeof(struct emu10k1_mpuout),
GFP_KERNEL))
> > >
> > > > > + if ((card->mpuout = kmalloc(sizeof(*card->mpuout),
GFP_KERNEL))
> > > >
> > > > Yeah, this is fine. The original posted omitted the '*' which was
> > > > not fine :)
> > >
> > > The only other thing left to ask, is which is easier to read when
> > > glancing through the code, and which is easier to read when maintaining
> > > the code. imho, ist the former for reading the code, i dont know about
> > > maintaing the code since i dont do that, however in my own projects i
> > > prefere the former when maintaing the code.
> >
> > It's the preference of the maintainer. It's a tossup: using the type
> > in the kmalloc makes the type being allocated obvious. But using
> > sizeof(*var) is a tiny bit more resistant to change.
> >
> > Neither one sufficiently affects long term maintenance AFAICS, so it's
> > personal preference, not any sort of kernel standard one way or the
> > other...
>
> The first one can be made a bit safer against changes by creating a `knew'
>
> macro that behaves like `new' in C++:
> | #define knew(type, flags) (type *)kmalloc(sizeof(type), (flags))
>
> If the types in the assignment don't match, gcc will tell you.

Well, since we are still beating this one to death, I'd written a "knew"
macro as well, and put it aside. It does the assignment for you too:

#define knew(p) ((p) = (typeof(p)) kmalloc(sizeof(*(p)), GFP_KERNEL))

Example:

struct foo { int a; int b; };
struct { struct foo *foo; } *foobar;

if (knew(foobar))
if (knew(foobar->foo))
printk("foo: %p\n", foobar->foo);

Terse and clear at the same time, and type safe. I still don't like it much.

--
Daniel
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:55    [W:0.058 / U:2.240 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site