[lkml]   [2001]   [Jun]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: Newbie idiotic questions.
David Flynn wrote:
> > Daniel Phillips wrote:
> > > Yep, the only thing left to resolve is whether Jeff had coffee or not.
> ;-)
> > >
> > > - if ((card->mpuout = kmalloc(sizeof(struct emu10k1_mpuout),
> > > + if ((card->mpuout = kmalloc(sizeof(*card->mpuout), GFP_KERNEL))
> >
> > Yeah, this is fine. The original posted omitted the '*' which was not
> > fine :)
> The only other thing left to ask, is which is easier to read when glancing
> through the code, and which is easier to read when maintaining the code.
> imho, ist the former for reading the code, i dont know about maintaing the
> code since i dont do that, however in my own projects i prefere the former
> when maintaing the code.

It's the preference of the maintainer. It's a tossup: using the type
in the kmalloc makes the type being allocated obvious. But using
sizeof(*var) is a tiny bit more resistant to change.

Neither one sufficiently affects long term maintenance AFAICS, so it's
personal preference, not any sort of kernel standard one way or the


Jeff Garzik | Andre the Giant has a posse.
Building 1024 |
MandrakeSoft |
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 12:55    [W:0.052 / U:0.368 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site