lkml.org 
[lkml]   [2001]   [Jun]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectsevere FS corruption with 2.4.6-pre2 + IBM jfs 0.3.4 patch
It's probably a JFS issue, but I thought I'd report this in case someone
is collecting and correlating filesystem corruption messages (Alan?).
Here is my sad story.

I have an Athlon 700MHZ, 256mb ram, AIC7XXX w 2/U2W drives system. I've
been running JFS on a small partition for a few weeks, JFS 0.3.1 under
2.4.5, 0.3.3 with 2.4.6-pre1 and yesterday I tried 2.4.6-pre2 with jfs
0.3.4.

I rebooted into the new kernel, and noticed one of those Red Hat [FAIL]
messages that pops up during the rc/init stages. It's a config problem
I've had for months, nothing new, but I decided I'd take care of it. I
logged into the console, ran emacs and it segfaulted. I ran 'dmesg' but
there was nothing (I was expecting to see an oops). I ran emacs again,
segfault. I tried logging in to another console, hang.

At this point I hit sysrq-T, and of everything that spewed by, I noticed
one process (which had scrolled to far off the screen to see the PID)
with a whole lot of
<dbdbdbdb> <dbdbdbdb> <dbdbdbdb> in the stack trace.

At this point I did sysrq-S-U-B and rebooted. End of story.

My filesystems were severely f***ed at this point. A total of about 60
seconds running this kernel and I was dead. My OS partition was
trashed, about 1/2 of it was unrecoverable. My home partition fared
better (good luck) but still had plenty of trashed inodes.

I've never had problems with any kernels before this...

That's my story,
David


--
David Mansfield (718) 963-2020
david@ultramaster.com
Ultramaster Group, LLC www.ultramaster.com
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:55    [W:0.069 / U:0.152 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site