lkml.org 
[lkml]   [2001]   [May]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject2.4 ide problems.
Hi,

I have Asus K7V motherboard with Athlon 750. I have one harddisc cnnected
to primary channel and CDrom connected to secondary.
The primary is connected with 40 pin 80 conductor ide cable and the
secondary is connected with 40 pin standard cable.

Everything but reading from the CDrom is working. When I insert a CD I can
list files on it but when I copy something to harddisk then size of the
file is the same but mdsum's do not match.

When I connect the CDrom to the primary cable everything is working.

When I connect the harddisc with standard cable to primary and CDrom with
80 conductor cable to secondary everything is working.

The main problem was when I tried to install RedHat 7.1 which uses 2.4.2
kernel....and it could not start install because some data read was bad.

So my guess is when CDrom is connected with standard cable kernel
gets some false information and the data cannot be read reliably from
CDrom.

Kernel outputs in both cases :
hda: 40088160 sectors (20525 MB) w/1961KiB Cache, CHS=2495/255/63, UDMA(66)
hdb: ATAPI 40X CD-ROM drive, 128kB Cache, UDMA(33)

If more testing is needed I'll be glad to help out ...


Janek

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:52    [W:0.029 / U:0.080 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site