[lkml]   [2001]   [May]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectABit KT7A-RAIN random lock ups
Hello listers,

as of yesterday I started to get random hard lockups. It was strange
because just before that I've never had one ... MB worked just fine
for now about two months. Until yesterday ...

I tried to boot 2.4.3-ac14, 2.4.4, 2.4.4-ac4 ... the same. Btw. I have
ACPI enabled, so sometimes I see lots of defunc processes
kacpidpc defunct ... and that number keeps growing. Ok, I see that new
kernel might misbehave but for example 2.4.3-ac14 used to work as charm
and there I see the same ... tons of defunc processes ... until fork:
resource temporary unavailable error ...

So that's not the kernel (my guess.). Last night I booted up win 98 to
play unreal tournament. Then booted back to linux ... and there we go
I hit strange pile of the problems and I don't know how to deal with them.

Tinkered for a while. Disable acpi or so ... trying to recompile kernels
- random lock ups. Sometimes it works fine for longer time sometimes it
hangs much faster ... most of time I saw kacpidpc defuncs ...

Yet later 5am. in the morning I gave up. ... But then I realized that win 98
did something ... lets try clean up BIOS'es (with jumper). Now it works just
fine again as it used to ...

Now I don't have a clue as to what was wrong ?

Win98 reprograms hardware ? and linux can't handle it in this "win98" state ?
Looks like it :(

No Ooops. Just plain hard lock up. No cpu not overclocked. Latest BIOS version.

My hardware :
00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 03)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)

00:07.1 IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 06)
00:07.2 USB Controller: VIA Technologies, Inc. UHCI USB (rev 16)
00:07.3 USB Controller: VIA Technologies, Inc. UHCI USB (rev 16)
00:07.4 Host bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
00:08.0 Ethernet controller: Bridgecom, Inc: Unknown device 0985 (rev 11)
00:0f.0 Multimedia audio controller: Creative Labs SB Live! EMU10000 (rev 07)
00:0f.1 Input device controller: Creative Labs SB Live! (rev 07)
01:00.0 VGA compatible controller: ATI Technologies Inc: Unknown device 5144

swoop@tweakster:~$ cat /proc/ide/via
----------VIA BusMastering IDE Configuration----------------
Driver Version: 3.23
South Bridge: VIA vt82c686b
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ ????
Revision: ISA 0x40 IDE 0x6
Highest DMA rate: UDMA100
BM-DMA base: 0xd000
PCI clock: 33MHz
Master Read Cycle IRDY: 0ws
Master Write Cycle IRDY: 0ws
BM IDE Status Register Read Retry: yes
Max DRDY Pulse Width: No limit

swoop@tweakster:~$ cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 6
model : 4
model name : AMD Athlon(tm) Processor
stepping : 2
cpu MHz : 850.047
cache size : 256 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr syscall mmxext 3dnowext 3dnow
bogomips : 1697.38

Any ideas ?
Zilvinas Valinskas
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 12:52    [W:0.022 / U:2.664 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site