lkml.org 
[lkml]   [2001]   [May]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: Status of ALi MAGiK 1 support in 2.4.?
Date
On Tuesday 29 May 2001 11:04, Bobby D. Bryant wrote:
> Alan Cox wrote:
> > > May 22 21:45:07 pollux kernel: ALI15X3: simplex device: DMA disabled
> > > May 22 21:45:07 pollux kernel: ide0: ALI15X3 Bus-Master DMA disabled
> > > (BIOS)
> > > May 22 21:45:07 pollux kernel: ALI15X3: simplex device: DMA disabled
> > > May 22 21:45:07 pollux kernel: ide1: ALI15X3 Bus-Master DMA disabled
> >
> > The DMA was off because the BIOS left it off.
>
> I just checked, and the BIOS auto-detect page for that drive shows PIO Mode
> 4 and Ultra DMA Mode 5. The BIOS also shows a summary chart during boot,
> just before the LILO prompt, and that summary also reports UDMA 5 for that
> drive. It really looks like the kernel is not getting the correct device
> info from the BIOS.

Just a blind guess, but this reminds me of a similar problem I had with
a different Athlon board a while ago. The BIOS and the driver disagreed
on the bits through which DMA capability was signalled. The fix that worked
for me was to enable both IDE channels (and use up two interrupts) though
I needed only the first channel.

--
Stefan R. Jaschke <stefan@jaschke-net.de>
http://www.jaschke-net.de
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:54    [W:0.030 / U:0.196 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site