lkml.org 
[lkml]   [2001]   [May]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRE: 2.4.5 -ac series broken on Sparc64
Date
Alan Cox responded to:
> Leif Sawyer, who wrote:
>> include/linux/irq.h:61: asm/hw_irq.h: No such file or directory
>> *** [sched.o] Error 1
>>
>> a find . -name 'hw_irq.h' shows appropriate versions
>> in i386, ia64, mips, mips64, alpha, ppc, parisc, um, and sh
>>
> The sparc64 tree isnt very well integrated with -ac. What I
> have I merge but where -ac varies from the Linus tree or the
> Linus tree requires new files tends to break it.
>
> It can probably be an empty file

This worked for me:

sed 's/_SH_/_SPARC64_/g' include/asm-sh/hw_irq.h >
include/asm-sparc64/hw_irq.h

make mrproper
cp ../.config .
make oldconfig
make dep && make

In file included from /usr/src/linux-2.4.5-ac4/include/linux/sched.h:9
/usr/src/linux-2.4.5-ac4/include/linux/binfmts.h:45: warning: `struct
mm_struct' declared inside parameter list
/usr/src/linux-2.4.5-ac4/include/linux/binfmts.h:45: warning: its scope is
only this definition or declaration,
/usr/src/linux-2.4.5-ac4/include/linux/binfmts.h:45: warning: which is
probably not what you want.

This warning is repeated for quite a good portion of the source files during
the make process, however the kernel seems to build correctly. Haven't
tried a reboot though.. :-\
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:54    [W:0.025 / U:1.972 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site