lkml.org 
[lkml]   [2001]   [May]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectProblems with ac12 kernels and up
Date
I have been running 2.4.4-ac11 for a few weeks, and decided to upgrade to
2.4.4-ac18. I applied the patches, compiled, and installed (all per usual),
and when booting, get a kernel panic at the point VFS is trying to mount the
root file system. I started working backwards to find the last kernel that
would boot. I got down to ac13, and the panics stopped, but I get the
following message:

Checking root filesystem. /dev/hde13 is mounted.
Cannot continue, aboorting.
*** An error occurred during the file system check.
*** Dropping you to a shell; the system will reboot
*** when you leave the shell.

Same for ac12. I used the same config file I used for ac11 and previous ac
kernels. I then decided to try the 2.4.5 kernel, which worked fine. I then
applied the 2.4.5-ac1 patches, and got the above message, again.

The system is an Abit KT7A-RAID w/ a 1Ghz Athlon. The dmesg output link
below describes the drive configuration. The BIOS is configured to boot
from the HPT-370.

As part of the test, I completely reinstalled the 2.4.4 kernel source,
applied the ac11 patch, and my config file, rebuilt and reinstalled. All
worked fine. Any thoughts on why this might be occurring?

I can provide any additional information as necessary. Here are the various
files:

http://jcwren.com/linux/config.txt - config file
http://jcwren.com/linux/dmesg.txt - ac11 dmesg log
http://jcwren.com/linux/lilo.txt - lilo.conf

I'm not smart enough to know how to capture the output for a kernel that
panics and halts. If I can provide any additional information for resolving
the problem, I would be happy to. Oh, and as best as I can tell before it
all scrolls by, the kernel reporting looks to be the same between all
kernels, with only the version being different.

--John

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:54    [W:0.062 / U:3.380 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site