lkml.org 
[lkml]   [2001]   [May]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: serpent loopback crypto "EXT2-fs: group descriptors corrupted"
spam goes to /dev/null wrote:
> i created a 10mb file called .enc2 with random data and ran "# losetup -e
> serpent -k 128 /dev/loop0 /mnt/hda7/.enc2"
> then i ran "# mke2fs /dev/loop0" and tried to "# mount /dev/loop0 /enc". but
> i get the following error messages when trying to mount:
>
> May 19 21:32:10 HOST2 kernel: EXT2-fs error (device loop(7,0)):
> ext2_check_descriptors: Block bitmap for group 16 not in group (block 0)!
> May 19 21:32:10 HOST2 kernel: EXT2-fs: group descriptors corrupted !
>
> im using kernel 2.4.4 patched with crypto patch 2.4.3.1 [and util linux
> 2.11a patched with the patch from that crypto patch]
> i also got the same errors with a 2gb file and by creating the loop device
> directly on my 19.5gb /dev/hda7
> i tried a few times again and sometimes the encrypted loopback fs works
> perfectly, sometimes the error occurs!?
> anyone got an idea what this is!? i will supply more information on request

International crypto patch is misdesigned and broken, period. If you don't
want to play russian roulette with your data, you should consider using
loop-AES package. loop-AES announcement is here:

http://mail.nl.linux.org/linux-crypto/2001-05/msg00003.html

Regards,
Jari Ruusu <jari.ruusu@pp.inet.fi>
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:53    [W:0.033 / U:0.892 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site