lkml.org 
[lkml]   [2001]   [May]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: eepro100 rev 12 problems
On Thu, 17 May 2001 16:59:04 +0100, James Fidell <james@cloud9.co.uk> wrote:
> I have two eepro100 interfaces in a machine, one rev 8, which works just
> fine, and another rev 12, which appears as a device when the kernel boots
> and can be configured with an IP address etc., but I can't get any data
> in or out of it. All the other hardware looks like it's working fine and
> all my rev 8 cards work, so I'm led to ask, are there any known problems
> with eepro100 rev 12 cards under 2.2.18?

Is this a real card, or is it built-in on the motherboard?

I don't think eepro100 has got much testing with rev > 9, though it should
have worked. All eepro100 chips are supposed to be backwards compatible with
the 82557, but maybe our driver initializes some registers in a way that
upsets newer chips. Not having docs for the newer chips doesn't help, either...

Intel's own e100 driver probably works, their code does things differently if
rev >= 12 (what they call the D102 revision). Give it a spin, I guess.

Ion

--
It is better to keep your mouth shut and be thought a fool,
than to open it and remove all doubt.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:53    [W:0.043 / U:1.548 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site