lkml.org 
[lkml]   [2001]   [May]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
SubjectRe: 2.4.4-ac6 compile error in plip.c
Date
On Thu, 10 May 2001 08:46:43 -0500, 
Moses McKnight <m_mcknight@surfbest.net> wrote:
>Hi, I get the following error trying to compile 2.4.4-ac6 using gcc
>2.95.4 (debian package).
>
>plip.c:1412: __setup_str_plip_setup causes a section type conflict

The first __initdata is marked as const, the second is not, a section
cannot contain both const and non-const data. Against 2.4.4-ac6.

Index: 4.16/drivers/net/plip.c
--- 4.16/drivers/net/plip.c Thu, 26 Apr 2001 12:38:49 +1000 kaos (linux-2.4/l/c/23_plip.c 1.2.1.3 644)
+++ 4.16(w)/drivers/net/plip.c Fri, 11 May 2001 14:50:39 +1000 kaos (linux-2.4/l/c/23_plip.c 1.2.1.3 644)
@@ -120,7 +120,7 @@

#include <linux/parport.h>

-static const char version[] __initdata =
+static char version[] __initdata =
KERN_INFO "NET3 PLIP version 2.4-parport gniibe@mri.co.jp\n";

/* Maximum number of devices to support. */
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:52    [W:0.061 / U:6.064 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site