lkml.org 
[lkml]   [2001]   [May]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectmmap2 causes SIGBUS on 2.4.4-ac6

After compiling and installing a 2.4.4-ac6 kernel I noticed that some
programs (notably 'grep') started crashing with 'Bus error's and
captured some 'strace' output... In all cases the last four lines of
output from strace are:

mmap2(0x8059000, 32768, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0) = 0x8059000
mmap2(0x8059000, 32768, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0xe00008) = 0x8059000
--- SIGBUS (Bus error) ---
+++ killed by SIGBUS +++

For those who would like to try and reproduce it, this command generates
it every time:

$ grep foo /usr/src/linux/Documentation/*


So there seems to be some mmap related problem with 2.4.4-ac6. I tried
running the exact same commands on a 2.2.17 and 2.2.19 and they do not
exhibit this behaviour. I can try some more 2.4.x kernels if the
information would be valuable?
If there is any other relevant information I can gather, then please let
me know and I'll be happy to provide it.

I tried searching for "mmap2" and "SIGBUS" on
http://www.uwsg.indiana.edu/hypermail/linux/kernel/ but could not find
any posts related to this, so I thought it would be ok to post this.


Best regards,
Jesper Juhl - juhl@eisenstein.dk

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:52    [W:0.048 / U:0.932 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site