lkml.org 
[lkml]   [2001]   [Apr]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Hi Francois,

> I'm having trouble getting a Cisco 340 wireless card to work with the
> aironet driver from 2.4.3-ac6. The driver loads fine but then cardmgr
> says:
>
> Apr 29 22:37:35 oleron cardmgr[613]: initializing socket 0
> Apr 29 22:37:35 oleron cardmgr[613]: socket 0: Aironet PC4800
> Apr 29 22:37:35 oleron cardmgr[613]: executing: 'modprobe aironet4500_core'
> Apr 29 22:37:35 oleron cardmgr[613]: executing: 'modprobe aironet4500_cs'
> Apr 29 22:37:36 oleron cardmgr[613]: get dev info on socket 0 failed: Resource temporarily unavailable
>
> I'm using the debian pcmcia-cs package version 3.1.22-0.2potato. I
> would be happy to help debug this but I won't have the card for long.
> Where should I go from there?
> My laptop is a Sony Vaio F560. I also have a 3com pcmcia network card
> which works just fine so I know that pcmcia is working. I tried the
> cisco card in each socket, with and without the 3com card at the same
> time. My /etc/pcmcia/config file says:
>
> --- cut here ---
> device "airo_cs"
> class "network" module "aironet4500_core", "aironet4500_cs"
> # class "network" module "airo", "airo_cs"
>
> card "Aironet PC4500"
> manfid 0x015f, 0x0005
> bind "airo_cs"
>
> card "Aironet PC4800"
> manfid 0x015f, 0x0007
> bind "airo_cs"
> --- cut here ---

The aironet drivers included in the kernel never worked for me (early
2.4.x-ac), so I use the airo and airo_cs modules which are disabled in
your pcmcia config.

You find the sources at www.cse.ucsc.edu/~breed (airo.c and airo_cs.c).
Copy them over the airo.c and airo_cs.c in pcmcia-cs-3.1.xx/wireless,
build the modules and there you are. :-)

Ookhoi
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:52    [W:0.070 / U:4.288 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site