lkml.org 
[lkml]   [2001]   [Apr]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [SOLVED]Re: 2.2.19 && ppa: total lockup. No problem with 2.2.17
Tim Waugh escribió:
>
> On Sat, Mar 31, 2001 at 01:59:39AM +0200, Juan Piernas Canovas wrote:
>
> > Yes!!!. It works. I am happy now :-)
>
> Unfortunately, the problem isn't solved, merely worked around. We
> need to figure out why this is happening in the first place.
:-(

>
> To recap, the system hangs completely when you load the ppa module.
Right

>
> Are you using any special parport/ppa parameters? Is this an SMP or a
> uniprocessor machine? Come to that, which architecture is it?
>
I have the same problem in two different machines but they both are UP.
However, my kernel configuration has SMP support enabled.

My modules.conf file is:

alias scsi_hostadapter ppa
alias parport_lowlevel parport_pc
options parport_pc io=0x378 irq=7


> Are there any messages displayed to the console when the hang happens?
> If you could scatter some printks around (KERN_CRIT so they show up on
> the console) to figure out the example point at which it's hanging,
> that would be great.

I stop klogd and syslogd services (that causes to display all kernel
messages on screen, doesn't it? and, when I load the ppa modules, the
machine simply hangs: no messages, no sysreq key anymore.

Bye!

Juan.

--
D. Juan Piernas Cánovas
Departamento de Ingeniería y Tecnología de Computadores
Facultad de Informática. Universidad de Murcia
Campus de Espinardo - 30080 Murcia (SPAIN)
Tel.: +34968367657 Fax: +34968364151
email: piernas@ditec.um.es
PGP public key:
http://pgp.rediris.es:11371/pks/lookup?search=piernas%40ditec.um.es&op=index
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:23    [W:0.067 / U:1.236 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site