[lkml]   [2001]   [Mar]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: Linux 2.4.2ac12 and ac13 breaks usb-visor
On Thu, Mar 08, 2001 at 02:01:03PM -0600, Erik DeBill wrote:
> On Wed, Mar 07, 2001 at 05:36:40PM -0800, Greg KH wrote:
> > I'll try to run with everything compiled into the kernel later tonight.
> > Does -ac14 with all of USB as modules, using usb-uhci work for you?
> Hmm... I was compiling usb-uhci and uhci directly into the kernel,
> then visor.o as a module.

You shouldn't be able to compile both usb-uhci and uhci into the kernel,
unless you tweak your .config file by hand.

> ac13 + crypto works with usb-uhci, usb-serial, and visor as modules.
> No problems.
> I've gone back and (re)tested with kernels 2.4.1, 2.4.2, ac[36],
> ac1[01234]. I can only get a crash on ac12 and ac13. 2.4.2 is broken
> after all, and everything after it. 2.4.2 and the ac kernels seem to
> fail on 'pilot-xfer /dev/usb/tts/1 -m scsi.pdb' (to install a zTXT
> into gutenpalm, doesn't matter what I'm sending), and things seem to
> go slower and have more problems as the versions increase. Then I can
> crash the system under ac12 and 13. This is using uhci compiled
> directly into kernel, with usb-serial and visor as modules.

What is the oops from when things crash?
Have you tried enabling debugging on the usb-serial drivers and looking
at what the visor driver spits out to the kernel debug log? I'd be
interested in seeing that.

Since you are reporting problems with a clean 2.4.2 kernel, I don't
think that the 1 line patch in ac12 is the cause of your problem.

What kind of hardware is this? What compiler? What version of
modutils? What is your .config? Do you have any other USB devices that
work properly (or not) in this system? Have you tried resetting your

> If uhci + visor is unsupported, might I suggest the following change
> to to warn people?

I've considered it, but I keep hoping that JE is going to fix the uhci
driver some day soon :)

There are other drivers that also do not work with the uhci.o driver do
to this bug.


greg k-h

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:29    [W:0.058 / U:2.800 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site