lkml.org 
[lkml]   [2001]   [Mar]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: RTL8139 conflicting with hard drive?
On Fri, Mar 30, 2001 at 08:52:08AM -0500, Tim Coleman wrote:
> I'm having a problem with a NIC I tried to install this morning.
> The chip on the NIC says its an RTL-8139B (it's a generic brand
> NIC, and I didn't really need anything fancy).
>
> When I install the NIC, and try to boot, the kernel complains
> about not being able to find the root device. If I take it out,
> everything is fine. I'm using kernel version 2.4.1, and my
> motherboard is an Asus A7V.
>
> I already have one RTL-8139B NIC installed, and it's just fine.
>
> I also noticed that the kernel seemed to detect it as an IDE
> controller, because two more IDE devices showed up in the boot
> messages.
>
> What could cause this? More importantly, what's a good remedy?

Sorry about posting that. I figured out what I was doing wrong,
and everything works now. The new NIC I put in was stealing the
hardware addresses used by my IDE controller.

A change to lilo.conf fixed everything.

--
Tim Coleman <tim@epenguin.org> [43.28 N 80.31 W]
Software Developer/Systems Administrator/RDBMS Specialist/Linux Advocate
University of Waterloo Honours Co-op Combinatorics & Optimization
"Go to Heaven for the climate, Hell for the company." -- Mark Twain

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:21    [W:0.036 / U:2.488 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site