lkml.org 
[lkml]   [2001]   [Mar]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: report bug: System reboots when accessing a loop-device over a second loop-device with 2.4.2-ac7
Hello!

Jens Axboe wrote:
>
> On Thu, Mar 01 2001, Mario Hermann wrote:
> > I tried the following commands with 2.4.2-ac7:
> >
> > losetup /dev/loop0 test.dat
> > losetup /dev/loop1 /dev/loop0
> > mke2fs /dev/loop1
> >
> > My System reboots immediatly. I tried it with 2.4.2-ac4,ac5 too -> same
> > effect.
> >
> > With 2.4.2 it hangs immediatly.
>
> This should make it work again.

There is another small bug with the loop over loop problem. Now it works
fine for
files but not for Devices:

losetup /dev/loop0 /dev/sr1
losetup /dev/loop1 /dev/loop0
dd if=/dev/loop1 of=test.dat bs=2048 count=1024

Makes dd hang. (BTW: /dev/sr1 is a CD-ROM)

Tried the same on /dev/hda1, /dev/sda1 with 2.4.2-ac7-your_patch and
with 2.4.2-ac8.

BTW: Did extensiv testing with and without the crypto patches. And all
other tests worked fine! :-)

--
Mario Hermann
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:22    [W:0.117 / U:1.056 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site