lkml.org 
[lkml]   [2001]   [Feb]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: d-link dfe-530 tx (bug-report)
Thomas Stewart wrote:
>
> >
> > CmdReset is not instant, it may need a delay. There is also a "force
> > software reset" operation that sounds good, I assume that one also
> > could use a delay so I gave it 6ms.
> >

6 ms is quite long:
I added a reset into tx_timeout, and that function should not take more
than 1 ms or so.
Did you find something about the delay in the documentation? Is it
possible to poll for reset completion?

I know that the winbond-840 chipset resets in 4 pci cycles - perhaps the
via-rhine is also fast?

>
> I applyed Manfred's patch but that changed nothing.
>

That's expected, my patch fixes another bug.
The NIC now recover from "Tx timeout" messages. ksa confirmed that, but
there is still a delay of a few seconds. I'll try to fix that.

> Then I applyed your patch and still changed nothing as you suspected.
> But there are regs that are different.
>
Did you run via-diag before or after loading the via-rhine module?

--
Manfred
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:55    [W:0.271 / U:3.688 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site