lkml.org 
[lkml]   [2001]   [Feb]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: d-link dfe-530 tx (bug-report)
On Mon, 5 Feb 2001, Manfred Spraul wrote:

> 6 ms is quite long:
> I added a reset into tx_timeout, and that function should not take more
> than 1 ms or so.
> Did you find something about the delay in the documentation? Is it
> possible to poll for reset completion?

I don't know how long. For testing I figured it might be nice with a long
delay, and I was hoping 6ms is long enough. If it changes anything, then
you can start working on getting it right. :)

There is a flag that may indicate reset complete (that's why the while
loop is there). It is supposed to do that for normal "CmdReset" so maybe
it does the same for "forced reset". I have no idea if it does.


But the reset doesn't seem to change much anyway.

The MII PHY (miffy?) is not responding but there are a few registers to
play with there. One clear difference is the PHY address, 8 vs 31 (and 31
has some special meaning for some other register).

The new register dumps needs to be examined for any vt6102 specifics that
are disabled.

/Urban

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:55    [W:0.082 / U:0.156 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site