lkml.org 
[lkml]   [2001]   [Feb]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    Subjectext3 fsck question
    Date
    We are running ext3 1.20 on a 2.2 kernel for about a year now on
    a flash disk. No problems to speak of that we know of yet.
    I just discovered that we do not have the fsck.ext3 nor any of
    the other efs2progs utilities.

    I applied the libs and other utilites from e2fsprogs by hand.
    I ran fsck.ext3 on my secondary partition and it ran fine. The boot fsck
    on / was complaining about something but I could not catch it.
    I then went single user and ran fsck.ext3 on / while mounted.
    Bad move. It ran and reported many errors which I chose to repair.
    It screwed the partition up to the point where it paniced on boot.
    I could still get it into single user but I found that lots of files were
    missing which happened to be located in lost+found (inittab, rc.local, etc).

    Anyone else have luck with this combination?
    Excuse the stupid question, but with ext3, do I really require the
    fsck.ext3?

    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:28    [W:0.024 / U:0.108 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site