[lkml]   [2001]   [Feb]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRE: trouble with 2.4.2 just released

    > The problem is with the version of ld you use. Some versions
    > are using
    > ld --oformat and other versions ld -oformat
    > This is quite a recent issue. So check the version of you linker.
    > You can solve the problem changing :
    > ./arch/i386/boot/Makefile: $(LD) -Ttext 0x0 -s -oformat
    > binary -o $@ $<
    > to --oformat
    > I think you hav not done any mistake, but the latest Debian
    > (unstable) version
    > of ld seems not to be right.

    The latest binutils in Debian potato will take either -oformat or --oformat,
    The lastest binutils in Debian unstable (just uploaded yesterday) will only
    take --oformat. So, if you modify arch/i386/boot/Makefile to read:

    $(LD) -Ttext 0x0 -s --oformat binary -o $@ $< ...blah blah blah
    you should be fine no matter which you're using...

    (Debian binutils maintainer)
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 13:17    [from the cache]
    ©2003-2014 Jasper Spaans. hosted at Digital Ocean