lkml.org 
[lkml]   [2001]   [Feb]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: DFE-530TX with no mac address

> >I did this and compiled it into the kernel. It detects it at boot (via-
> >rhine v1.08-LK1.1.6 8/9/2000 Donald Becker) but says the
> >hardware address (mac address?) is 00-00-00-00-00-00.

This is a good example of what is missed by not copying the exact message.
For example, mine says:

eth0: VIA VT3043 Rhine at 0xd400, 00:50:ba:a4:15:86, IRQ 19.
eth0: MII PHY found at address 8, status 0x782d advertising 05e1 Link 0000.

Does it say "VIA VT6102 Rhine-II" for both of you?
If not, could you do an 'lspci -n'?

My VT3043 survives win98, but it may be a new feature in the newer chip.
It may be a bios setting or something ...


> I have an identical card, which usually works - except when I've rebooted
> from Windows, when it shows the above symptoms. After using Windows, I
> have to power the machine off, including turning off the "standby power"
> switch on the PSU, then turn it back on and boot straight into Linux. Very
> occasionally it also loses "identity" and requires a similar reset, even
> when running Linux.

Yes, the card is in some (for the linux driver) unknown state. Powering
off completely resets it. Something that could help someone find out what
is going on is running these two commands, both when the card is working
and when it is not.

via-diag -aaeemm
lspci -vvvxxx -d 1106:3065

via-diag is available from http://www.scyld.com/diag/index.html

(1106:3065 is the pci id, if lspci -n gives you a different number you use
that of course.)

/Urban

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:28    [W:0.044 / U:1.148 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site