lkml.org 
[lkml]   [2001]   [Feb]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: IDE DMA Problems...system hangs
Date
From
> Anybody else having these problems with a ide raid 5?
> The Raid 5 performance should also be questioned..here are some number
> returned by hdparam

You will get horribly bad performance off raid5 if you have stripes on both
hda/hdb or hdc/hdd etc.

> Feb 13 05:23:27 bertha kernel: hdo: dma_intr: status=0x51 { DriveReady
> SeekComplete Error }
> Feb 13 05:23:27 bertha kernel: hdo: dma_intr: error=0x84 { DriveStatusError
> BadCRC }

You have inadequate cabling. CRC errors are indications of that. Make sure you
are using sufficiently short cables for ATA33 and proper 80pin ATA66 cables.

> Feb 13 12:12:42 bertha kernel: hdg: irq timeout: status=0x50 { DriveReady
> SeekComplete }
> Feb 13 12:13:02 bertha kernel: hdg: timeout waiting for DMA

This could be cabling too, cant be sure

> Feb 13 12:13:12 bertha kernel: hdg: DMA disabled

It gave up using DMA

> Feb 13 12:13:12 bertha kernel: ide3: reset: success <------- * SYSTEM HUNG
> AT THIS POINT *

Ok thats a reasonable behaviour, except it shouldnt have then hung.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:17    [W:0.079 / U:4.860 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site