lkml.org 
[lkml]   [2001]   [Dec]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectSMP, MD and Promise IDE Controllers
Hi, everyone! Got an issue with the APIC, SMP and possible MD code - 
I've got this dual Athlon box with two Promise Ultra100TX2 cards. Each
has two IBM disks on it, for a total of four. I use the RH7.2 installer
to install software raid 0, and everything works fine! No errors,
nothing. Absolutely perfect. When I boot the *real* kernel, however, I
get a number of things:

- I/O errors to hdi and hdk (the two disks on the second promise card -
which isn't UDMA because the ports can't be probed. The two disks on the
first are UDMA - never any errors on those)
- Spurious interrupt #7
- APIC error - AMD Errata #22, try noapic.

The thing works perfectly in single processor mode, by the way. I also
tried noapic (although I still get the message to try noapic! Does this
flag do anything!?) and also tried changing two bios options - the MP
table to revision 1.1 or 1.4, and this strange option to "use IRQ table
entries in MP" or some such thing. I tried both options, on and off, and
I still get these errors. It seems to be apic related - anyone out there
have any ideas on how I might get it working!? I also tried 2.4.14 to a
limited fashion, but since he I/O errors corrupt the fs, so I can't try
too many things before I have to re-install!

Thanks!!

-Jeff.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:18    [W:0.026 / U:4.456 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site