[lkml]   [2001]   [Dec]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectProblem with kernel nfs server in 2.4.17-rc1
Hello all,

I run constantly in a problem with knfsd (or related) that looks like this:
After several hours clients cannot mount via nfs any more, they get:

db:/usr/src/packages/SOURCES # mount /backup
mount: admin:/p2/backup/db failed, reason given by server: Permission denied

On the server I get:

Dec 17 14:09:54 admin rpc.mountd: getfh failed: Operation not permitted

This issue can always be solved by simply restarting the kernel nfs server.
Does this sound familiar to anybody? I tend to believe this is yet another
issue with knfsd getting into troubles with failed allocs. I can test whatever,
if someone tells me how and what.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:14    [W:0.059 / U:39.692 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site