lkml.org 
[lkml]   [2001]   [Dec]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: aic7xxx freezes with kernel 2.4.13 - solved
Date
Hi,

For the archives: my problem is solved. The problem went away after
removing a (crashed) IDE disk and the HPT370 IDE controller it was
connected to. I replaced the faulty IDE disk with a SCSI disk and
now all my IDE and SCSI problems are gone.

Thanks for your input,
Pim

> >On Wed, Nov 07, 2001 at 04:20:17PM +0100, Pim Zandbergen wrote:
> >> Hi,
> >>
> >> I've got a Dell PowerEdge 1300 with dual PIII's and dual aic7xxx
> >> controllers. One controller is onboard, the other is in a PCI slot.
> >>
> >> The system is running Red Hat 7.1 with kernel 2.4.13.
> >>
> >> Lately, this system is experiencing freezes that may last one or two
> >> minutes. These usually occur during heavy Samba activity. After the
> >> freeze, the system usually recovers, but by then, the Samba clients
> >> have timed out their operations.
> >>
> >> Syslog shows the freezes are related to the SCSI subsystem. I'm having
> >> trouble interpreting this information. Is my hardware suspect or could
> >> this be a driver bug?
> >>
> >> Syslog entries (with aic7xxx=verbose) showing the boot process and a
> >> system freeze can be found on
> >>
> >> http://www.macroscoop.nl/~pim/aic7xxx/syslog.html (98.080 bytes) or
> >> http://www.macroscoop.nl/~pim/aic7xxx/syslog.gz (6.410 bytes)
>
> In the case of these traces, it appears that the bus is not up to
> snuff for the negotiated speed. We're in data-out phase, our DMA
> engine is enabled, our FIFO is full of data to send, but the target
> has not requested any more data. This means that either the controller
> missed a REQ or the target missed an ACK. I would verify your cabling
> and termination.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:14    [W:0.112 / U:0.388 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site