lkml.org 
[lkml]   [2001]   [Nov]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.4.14-pre8 Alt-SysRq-[TM] failure during lockup...
"Eric W. Biederman" wrote:
>
> Summary: I triggered a condition in 2.4.14-pre8 where SysRq triggered
> but would not print reports. I managed to unstick the condition but
> had played to much to determine the root cause. My guess is that
> somehow my default loglevel was messed up. Full information is
> provided just case I did not muddy the waters too much.

Do you know what the console loglevel was when you tried
to use Alt-SysRq-M (show_mem) or Alt-SysRq-T (show tasks ==
show_state)? (first value listed in /proc/sys/kernel/printk file)

show_mem() and show_state() don't modify the current value of
console_loglevel; they depend on the sysrq handler to do that.
That value could be too low/small.

E.g., if console_loglevel is 4, show_mem and show_state don't
show me anything on the console either, but they are added
to the log file.

[rubout]

> I then tried playing with sysrq and this is where I got worried.
> Alt-SysRq-Space gave the menu as normal.
> Alt-SysRq-M (showMem) printed just: "SysRq: Show Memory"
> Alt-SysRq-T (showTasks) printed just: "Sysrq: Show State"
>
> Which is extremely strange the reports which should be at a higher
> loglevel were not displayed.
>
> Then I typoed and pressed. Alt-SysRq-E (tErm) and I started getting the
> reports back.

Aye, sysrq_handle_term sets console_loglevel to 8 and leaves it there.

[rubout]

~Randy
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:12    [W:0.072 / U:0.652 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site