lkml.org 
[lkml]   [2001]   [Nov]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectFile system
here are my problems :
1.
i implemented a file system on redhat linux 6.2 named
it pfs(peaceful file system). inserted it as a module
using insmod. got inserted peacefully. the fs worked
on linux 6.2 :mouunted, ls, cat ,etc. .... But
consider the following problem:
i unmount the dev i had mounted as a pfs file system.
then i try to rmmod the pfs module :
what i get is:
pfs: Device or resource busy.

i tried similar stuff with minix, ensured that the
module functionality of pfs, the include files of pfs
is identical to minix.
STILL THE SAME TROUBLE.

2.
i compile this code on redhat 7.2 : compiled ok
(after
(i):-i made necessary changes in some functions which
had witnessed a change in their definitions, etc..
anyway fugget it
(ii):-got some directions while compiling regarding
the compile time options : tried them and things got
ok
).
then i try to do insmod: result ... i get many
functions as unresolved symbol. i check for the same
functions in ext3fs(which is added as a module to the
7.2's kernel).. i find the "unresolved" functions up
and working fine for ext3fs. i make sure that my
includes etc. are identical to ext3fs's : no use.
i bang my head : no use.
so why this problem

-abhishek

=====
Don't say Goodbye say Goodluck
============================================================
Abhishek Rai
3rd year,B.Tech, Computer Science and Engineering
IIT KGP,India
abbashake007@yahoo.com
============================================================


__________________________________________________
Do You Yahoo!?
Yahoo! GeoCities - quick and easy web site hosting, just $8.95/month.
http://geocities.yahoo.com/ps/info1
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:13    [W:0.028 / U:2.972 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site