lkml.org 
[lkml]   [2001]   [Nov]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectDid someone try to boot 2.4.16 on a 386 ?
Hi !

I just happened to test 2.4.16 on my 386 (firewall)
and
just after the message "Uncompressing kernel", the PC
reboots just as after an illegal op, or a triple
fault. I tried
to diff between 2.4.13-ac8 (which previously worked)
and 2.4.16, but I don't see many changes (except the
CR2 patch that I reverted in 2.4.13-ac8 anyway, and
which is still not present in 2.4.16).

I also checked for illegal instructions like there has
already been in the past (cmov, bswap, cmpxchg) but
couldn't find any. I could only find some rdmsr, wrmsr
and cpuid in functions which, to my knowledge, are not
called when an i386 boots.

I'm sorry I don't have the .config right here, but
it's
simply minimalistic : module, ide, iptables, serial
console. Of course, I've already checked there were no
accidental CONFIG_SMP nor MTRR ...

The system has 8 MB of RAM, and 16 MB of
CompactFlash connected to the IDE controller. The
onboard VGA is enabled and didn't cause any problem
before, but it may be possible that the reboots
happens
when the system tries to change the video mode.

Since I spent a long time recompiling with several
options, I didn't yet test if vanilla 2.4.13-2.4.15
could
boot on this PC. I didn't test with a serial console
either.

So my two questions are :
- does anybody happen to boot 2.4.16 on a 386 ?
- does someone have an idea of another change in the

kernel that could affect its boot on such a
machine ?

Regards,
Willy


___________________________________________________________
Do You Yahoo!? -- Une adresse @yahoo.fr gratuite et en français !
Yahoo! Courrier : http://courrier.yahoo.fr
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:13    [W:0.028 / U:2.768 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site