lkml.org 
[lkml]   [2001]   [Nov]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRouting table problems
From
Date
Hi All,

I am facing a problem ( ???, maybe it works that way, but i really dont
know ) with regards to routing table behavior when using ifconfig on a
network interface.

1) netstat -nr Shows my default gateway for network 0.0.0.0

2) ifconfig eth0 down

3) netstat -nr No entry for the default gateway is shown (
understandable )

4) ifconfig eth0 up

After the the 4'th command, my interface is up and has it's IP address set
correctly. But .....

netstat -nr does not show my default gateway for network 0.0.0.0 !!.
Pinging any IP outside of my subnet, results in "Network is unreachable"
error.

Is is meant to be that way ? or is there a problem here ?

I've tried it on kernel versions, 2.4.0, 2.4.5 & 2.4.15

FYI : This has been tried using both DHCP and Static IP.

Thanks in advance !

Regards,

Raj


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:13    [W:0.080 / U:0.252 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site