lkml.org 
[lkml]   [2001]   [Nov]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject2.4.12 ... 2.4.16, /dev/tty
Hi,

still having problems (starting with kernel 2.4.12) with
the /dev/tty device:

When logging in on the console and trying the "ps" command,
is will list _all_ processes and not only those which are
attached to the controlling terminal. This seemed a little
bit suspicious.

Now, trying

echo some text >/dev/tty

returns

bash: /dev/tty: No such device or address

Now trying the command

tty

says

/dev/tty1

Now, I tried

echo some text >/dev/tty1

It echoed correctly

some text

on the console.

Then, I tried

echo some text >/dev/tty

Now (!!!???) it echoes correctly "some text".

It seems that the cmd

echo some text > `tty`

will repair something, but I don't no what and why.

-----------------------------------------------------

The above described problem first appeared with Kernel 2.4.12,
I tried the following kernels (now 2.4.16), BUT WITH NO SUCCESS.
Kernel 2.4.10 was _not buggy_.

Additionally, the problem does not arise on all my LINUX workstations,
but only on some. And it does not depend on the harware platform.
And is does not depend on the distribution. Both on RedHat 7.1 ans
Redhat 7.2 having the problem.

Regards


Joachim Backes

--

Joachim Backes <backes@rhrk.uni-kl.de> | Univ. of Kaiserslautern
Computer Center, High Performance Computing | Phone: +49-631-205-2438
D-67653 Kaiserslautern, PO Box 3049, Germany | Fax: +49-631-205-3056
---------------------------------------------+------------------------
WWW: http://hlrwm.rhrk.uni-kl.de/home/staff/backes.html

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:13    [W:0.082 / U:2.804 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site