lkml.org 
[lkml]   [2001]   [Nov]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: anyone got the same problem with DIGITAL 21143 network card ?
On Thu, Nov 22, 2001 at 09:50:10PM +0800, Ishak Hartono wrote:
> I tried to compile 2.4.14 and successfully detect the digital 21143 network
> card, however, i can't ping out
>
> this is just a curiosity, because it works with my 2.2.17 kernel
>
> the reason why i didn't move to 2.4.x yet because i got this problem with
> 2.4.5 as well and gave it a try again on 2.4.14 kernel
>
> anyone know what should i check in the system other than blaming on the
> kernel ?

I'm not sure if this counts or not. One of my kernel build boxes for ARM
is a NetWinder, which I run over the 100MBit port (which is a 21143). I've
been building kernels on it for ages under various 2.4 kernel versions (both
Linus and -ac) without any problems.

Linux sturm 2.4.15-pre5 #32 Sat Nov 17 22:10:45 GMT 2001 armv4l unknown

lspci reports:

00:0a.0 Ethernet controller: Digital Equipment Corporation DECchip 21142/43 (rev 41)
Subsystem: Unknown device 574e:5554
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 20 min, 40 max, 32 set, cache line size 08
Interrupt: pin A routed to IRQ 22
Region 0: I/O ports at 6000 [size=128]
Region 1: Memory at c1000000 (32-bit, non-prefetchable) [size=1K]
Expansion ROM at 80000000 [disabled] [size=256K]

Note that I haven't tried 2.4.14 on this machine, only 2.4.13-ac8 and
2.4.15-pre*.

--
Russell King (rmk@arm.linux.org.uk) The developer of ARM Linux
http://www.arm.linux.org.uk/personal/aboutme.html

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:13    [W:0.046 / U:3.744 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site