lkml.org 
[lkml]   [2001]   [Nov]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectVia onboard audio
From
Date
Hi!

I've recently purchased a Compaq Presario 700 laptop that has a Via
motherboard with onboard audio.

When I load the via82cxxx_audio driver (kernel 2.4.12), I hear the
speakers pop, but no sound ever plays. I'm check the mixer, and the
volume is up as necessary. Interrupts are occuring for the device in
/proc/interrupts. All the necessary (that I know of) modules are
loaded, such as sound/soundcore/ac97_codec.

I tried the ALSA drivers as well, and had less success. For them, I had
to use the Via 686a driver (/proc/pci reports that I have a VT82C686).
However, althouh the driver loaded, and I head my speakers pop, ALSA
utils reported that i had no configured sound cards, and no OSS based
utils worked (/dev/dsp and /dev/mixer reported invalid devices). I did
go thru and make sure my ALSA /dev entries were created and correct.

So now I'm back to the OSS drivers, but still no luck. If there's
anymore information I can post to figure out how to get this to work, or
maybe modify some drivers, please let me know what I need to do. I
don't want to have to use another OS just to hear sound. ~,^

Thanks everyone,
Sean Etc.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:12    [W:0.073 / U:5.540 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site