lkml.org 
[lkml]   [2001]   [Nov]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Compile failed on fs.o for 2.4.15-pre4
I wrote:
> After making the patch to setup.c so that it would compile, I ran into a
> linking error. I have a fairly standard uniprocessor PIII system. I can
> make my config file available to anyone that thinks it will help.

> fs/fs.o: In function `dput':
> fs/fs.o(.text+0x10fb8): undefined reference to `atomic_dec_and_lock'
> make: *** [vmlinux] Error 1

Dick Johnson replied:
> Assuming that your version is similar to mine....
>
> In ...linux/fs/dcache.c add ...
> #include <linux/spinlock.h>

I tried that. The error is coming from fs/dcache.c, and it does look like
including that file is a good idea, but no matter where I put the #include
directive, I still get the same error.

[Please CC responses to me]

--PC
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:13    [W:0.036 / U:0.332 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site