[lkml]   [2001]   [Nov]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectProblem with i820 AGP patch
Your patch to add AGP support for i820 chipset doesn't work for me, if I
load agpgart module with agp_try_unsupported=1 I get:

Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 262M
agpgart: Trying generic Intel routines for device id: 2501
agpgart: AGP aperture is 256M @ 0xd0000000

That device id is different from the corresponding line in apg.h:174
#define PCI_DEVICE_ID_INTEL_820_0 0x2500

I tried to change that line in:
#define PCI_DEVICE_ID_INTEL_820_0 0x2501

And it worked! But I don't know why the id for your chip is different
from mine...

My motherboard is an Asus P3C2000 with a P3 500 running kernel 2.4.14

I've also another problem (I think AGP related) with DRI/DRM ang XFree
4.1.0, but I'm still working on it.
If I try running some OpenGL app with more than 256Mb of RAM, the system hangs
(need hard reset, no SysReq works). This happens with 2.4.13 and 2.4.14,
before I hadn't tried since I had only 128Mb...)
Someone can please tell me if this problem has something to do with
having a "Maximum main memory to use for agp memory" value grater than
AGP aperture value ?

Daniele Venzano
Senior member of the Linux User Group Genova, Italy (LUGGe)

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:13    [W:0.106 / U:0.256 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site