lkml.org 
[lkml]   [2001]   [Nov]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: DMA problem (?) w/ 2.4.6-xfs and ServerWorks OSB4 Chipset
On Tue, Nov 13, 2001 at 09:51:21AM +0000, Alan Cox wrote:
> > I ask because I'm still having major problems with the OSB4 chipset on
> > 2.4.14. I've had to disable DMA completely on my boxes to avoid IDE errors
> > and fs corruption. Does anyone know of a patch that addresses the issues
> > with this chipset?
>
> No. I spent some time digging into this problem with both Serverworks and
> Red Hat customers. With certain disks, certain OSB4 revisions and UDMA
> the controller occasionally gets "stuck", the next DMA it issues starts
> by reissuing the last 4 bytes of the previous request and the entire thing
> goes totally to crap.
>
> The -ac tree will detect this case and panic and hang the machine solid to
> avoid actual disk corruption. The real fix appears to be "dont do UDMA on
> the OSB4". The CSB5 seems fine.

I am having problems with both UDMA and Multiword DMA. The problem doesn't
go away unless I disable CONFIG_IDEDMA_PCI_AUTO.

I don't know if there is actual FS corruption with MWord DMA, but there is
definitely a "hang" for a few seconds accompanied by a DMA error.

--Adam

--
Adam McKenna <adam@flounder.net> | GPG: 17A4 11F7 5E7E C2E7 08AA
http://flounder.net/publickey.html | 38B0 05D0 8BF7 2C6D 110A
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:13    [W:0.078 / U:1.356 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site