lkml.org 
[lkml]   [2001]   [Nov]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject/proc/<pidnumber>/stat hangs reading process
Hello,

basically this posting is about the same problem as one I posted in
September:

http://www.uwsg.iu.edu/hypermail/linux/kernel/0109.0/0764.html

It's essentially the same situation: I was running mozilla and it stopped
responding to any input. I tried to kill it with control-c, kill and
finally with kill -9, but none helped. When I tried to look at the output
of top and ps, the exactly same symptons appeared; those processes didn't
finish and can't be killed either. When I do strace ps the output ends at:

stat64("/proc/16515", {st_mode=S_IFDIR|0555, st_size=0, ...}) = 0
open("/proc/16515/stat", O_RDONLY) = 7
read(7,

Kernel information at this time:

Linux renttu.lnet.lut.fi 2.4.12 #1 Wed Oct 17 20:09:21 EEST 2001 i686
unknown

(in September I was running 2.4.8)

Additional differences compared to the previous post:

- the machine has now 512 MB of DDR memory
- the /var/log/messages entry didn't appear this time, so I guess it was
probably something unrelated last time.

I'll keep the machine running until evening and upgrade to newer kernel
in case someone has any suggestions to try for getting more information
about the problem. Anyone knows if this problem is fixed in newer kernels?
(Any suggestions for the kernel to go - 2.4.13-ac, 2.4.14, 2.4.15-pre4 ?)

I've not subscribed to the list, because my mail traffic is already quite
overwhelming, so I appreciate if replies will be CC'ed to me, althought I
follow the list now and then with the archive on the web.

--
/-------------------------------------------------------------------------\
I Fantasy, Sci-fi, Linux, Amiga, Telecommunications, Oldfield, Vangelis I
I Seti@Home, Steady relationship, more at http://www.lut.fi/%7emyrjola/ I
\-------------------------------------------------------------------------/

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:13    [W:0.045 / U:2.408 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site