lkml.org 
[lkml]   [2001]   [Nov]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectIDE tape problems
From
I have an interesting issue with the ide-tape driver. It manages 
to truncate anything read from tape[0]. From a very limited data
set, it appears that the longer the data on the tape, the more
blocks are truncated.

I've tried 2.4.6 and 2.4.14. Tape drive is a Seagate STT20000A,
MB is a KT7-RAID w/ 768MB mem and an Athlon 1200. Drive is slave
on the second channel (on the VIA controller, not the highpoint
one). Other device is a BCD E520C CD-ROM. The tape is a 10G TR-5
from Imation.

This setup does work with SCSI emulation, though the console
gets spammed with messages like:
st0: Error with sense data: Current st09:00: sense key Illegal Request
Additional sense indicates Invalid command operation code

Amanda works with the SCSI setup; with the IDE setup, amlabel
fails. I've tried re-tensioning the tape; no help.

I'm willing to try patches, incantations, etc.

[0] I assume it is truncating on the read side, but it could
very well be doing it on the write side.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:13    [W:0.041 / U:0.304 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site