lkml.org 
[lkml]   [2001]   [Nov]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: mysterious power off problem 2.4.10-2.4.14 on laptop

Linda,

it could be a bad BIOS.

I don't know if this helps, but anyway:

I had a similar problem, but in ma case the machine just went to suspend
mode - annoying, but somewhat easier to track. Just like in your case,
nothing worked; switching off APM in BIOS, disabling APM in kernel, etc.
no matter what I did (typing, using the mouse), the machine suspended.

Well:

Question 1: Are you running Windows on that machine, too? If no, you
have a different problem; as said, most probably caused by a bad BIOS.
That it worked under a previous 2.4.x kernel doesn't mean a lot; apm
could have interpreted bad (malformed) apm messages in a different way
(just a guess).

Question 2: If yes: Did you ever happen to try to boot (ie cold boot =
switch ON) the machine with AC power chord connected after a Windows
session?

In my case, it was a bug in the BIOS. This piece of sh** - right after a
Windows session - reported a battery charging status of _more_ than
100%, leading into miscomprehending APM messages from the BIOS - leading
into APM confusion. Strange enough, this _only_ happened when _switching
on_ the machine on battery. It never happens when booting with AC
connected.

Even more strange, in my case it is sufficient to cold boot the machine
_once_ after running Windows on AC to avoid the effect in the future
(however, until running windows again).

Good luck,

Thomas

--
Thomas Winischhofer
Vienna/Austria Check it out:
mailto:tw@webit.com *** http://www.webit.com/tw
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:13    [W:0.040 / U:2.112 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site