lkml.org 
[lkml]   [2001]   [Nov]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: "unkillable processes" in linux 2.4.11 to 2.4.14-pre6

I have the exact same problem and it all started with 2.4.11. All I've
managed to find out is that it's related to the devfs symlink semaphores.

/Per

On Thu, 1 Nov 2001, Ricardo Martins wrote:

> I'm using Linux kernel 2.4.10, and since the fatidic 2.4.11 release ( i
> tried 2.4.11 (one day :)))) 2.4.12, 2.4.13 and 2.4.14-pre6) I get the
> same bug on and on (that means I can reproduce the experience and obtain
> the same results).
>
> Procedure
> In X windows (version 4.1.0 compiled from the sources) when writing
> "exit" in xterm to close the terminal emulator, the window freezes, and
> from that moment on, every process becomes "unkillable", including xterm
> and X (ps also freezes), and there's no way to shutdown GNU/Linux in a
> sane way (must hit reset or poweroff).
>
> Environment
> I used Glibc 2.2.4 and GCC 3.0.1 (tried with 2.95.3, obtained the same
> results).
>
> The odd thing is, that with the same configuration, kernel 2.4.10 works
> just fine, but every other release since then ends up doing the same
> thing (the system can't maintain integrity after writing "exit" and
> hiting enter in xterm).
>
> Please help me, I getting slightly mad with the situation.
>
> Ricardo Martins
>

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:12    [W:0.041 / U:0.908 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site