lkml.org 
[lkml]   [2001]   [Oct]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: problem with ide-scsi and IDE tape drive
    On Tue, 30 Oct 2001, Richard Kettlewell wrote:

    > Hi,
    >
    > I have a Seagate STT20000A IDE tape drive, which I am trying to use
    > with the ide-scsi driver. It worked well enough when moving data
    > around to repartition recently, but I have discovered a repeatable
    > problem.
    >
    > If I try and save a tar to the tape twice in succession, rewinding and
    > reading forward to the same point each time first, the second attempt
    > fails (details below).
    [details cut]

    Looking at your log everything seems to work perfectly from the point of
    view of the drivers. The problem is that the first write command (from the
    log cmd: a 1 0 0 3c 0 Len: 30720) is refused by your drive (the sense key
    Illegal Request). The command looks OK (i.e., it is a write of 60 512 byte
    blocks in fixed block mode).

    Does your drive only accept writes from the beginning of the tape (there
    are drives that have this limitation)? In this case the problem is that
    you rewind and space forward between the two tar commands. You don't have
    to rewind between the commands. The same result is obtained if you just
    use two consecutive tar commands (and this means that writing only starts
    from the beginning of the tape, from the drive's point of view).

    Kai


    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:12    [W:0.023 / U:59.060 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site