lkml.org 
[lkml]   [2001]   [Oct]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectProblem with SanDisk Compact Flash disks on IDE with kernel 2.4.x
I have a lot of problems when trying to use a SanDisk Compact Flash
card with an IDE adapter as an IDE disk on kernel 2.4.x.
The Compact Flash disks may be used perfectly with the old age MSDOS
6.2 either alone or with a normal IDE disk on the same controller. It
is also possible to use the Compact Flash with success with kernel
2.2.14 and 2.2.16.

When used with kernel 2.4.x (tried 2,5,7,12,13, various compile
options) I have so far found it impossible to get the Compact Flash
working together with a standard IDE disk on the same controller. A
typical scenario is: Standard IDE disk as hda full system installed,
the CF with IDE adapter as hdb (empty/unformatted/dos formatted /ext2
formatted, tried "everything"). The boot sequence is normal until LILO
attempts to mount VFS. Then no disk is accessible on the IDE bus, and
I get kernel panic. Identical sympthoms are seen when using an IDE
FlashDrive from SanDisk.

I have installed a stripped down system based on kernel 2.2.14 on one
CF disk as hda, that works, with or without a normal IDE disk as hdb.
If I change the kernel on that CF to 2.4.13 and removes the hdb IDE
disk, the kernel is able to mount VFS and complete normal boot.

Any ideas for fix / workaround, I haven't found anything in the
archives?

System info:

CPU card: Aaeon 6890B with Celeron and 440BX chipset.
SanDisk 64 MB Compact Flash card: SDCFB-64 or
SanDisk 96 MB Flash Drive (IDE interface) : SD25B-96

Audun Myrhol
R&D engineer

((((((((((((((((((( 8-)§ ))))))))))))))))))))))
Q-Free Tolling AS
N-7443 Trondheim MAILTO:audun@q-free.com
Norway http://www.q-free.com
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:18    [W:0.061 / U:17.868 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site