lkml.org 
[lkml]   [2001]   [Oct]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject2.2.0-preXX compile errors solved

I was getting compile errors for 2.2.20-pre11 on a Slackware 3.6 box. Since the
errors involved undefined symbols and unmatched struct definitions, I made the
silly assumption that I was missing a header file somewhere.

After looking at it a bit more carefully and repatching, I finally noticed that
patch was failing partway through... :(

The problem goes back to 2.2.20-pre4, where the following appears in the section
of the patch relating to arch/ppc/kernel/openpic.c:

-#endif /* CONFIG_PMAC_PBOOK */
\ No newline at end of file
+#endif /* CONFIG_PMAC_PBOOK */

It would appear that later versions of diff output the "\ No newline..." line
when they find a file that has, surprise surprise, no newline at the end.
What I failed to realise was that older versions of patch (in my case, 2.1b)
choke on this kind of thing with a malformed patch error. I tried a later
version (2.5), which copes with it quite happily.

While I realise that the answer will most likely be "Upgrade your userland!", it
might be a good idea to consider filtering these lines out for the 2.2 series,
since it's more likely to be run on older boxes.

Bruce
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:11    [W:0.027 / U:2.688 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site