lkml.org 
[lkml]   [2001]   [Oct]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: SiS/Trident 4DWave sound driver
At 03:36 PM 26/10/01 +0100, Alan Cox wrote:
> > though the codec->codec_read(codec, AC97_VENDOR_ID#) isn't returning the
> > codec value for this system at all.
>
>Something is failing to bring up the AC97 codec bus and/or set it up
>properly. Can you find exactly which patch broke that for you (you'll
>possibly want to keep fixing the codec table as you test older ones)

Well the thing is this system has never had working sound. I've got 2 of
these machines, both with the array fix, and neither get sound. I've tried
2.4.7 (which didn't have the array fix), 2.4.9, 2.4.12, 2.4.13, and I'm
about to try some earlier kernels, but since this chip is "notoriously new"
I would not be suprised if it's not returning anything for what should be
valid codec calls. Will take a peek and get back to you.

PS: This is one of these SiS630S all in one integrated things, and also one
of the offenders in that SiS FrameBuffer stuff we've been discussing, so I
wouldn't be suprised in anomalies at all.


AMC Enterprises P/L - Stuart Young
First Floor - Network and Systems Admin
3 Chesterville Rd - sgy@amc.com.au
Cheltenham Vic 3192 - Ph: (03) 9584-2700
http://www.amc.com.au/ - Fax: (03) 9584-2755

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:11    [W:0.075 / U:0.508 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site