lkml.org 
[lkml]   [2001]   [Oct]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: strange hangs with kernel 2.4.12 (and 13)
Date
Michael Reinelt <reinelt@eunet.at> wrote:
> Hi there,
>
> I've got some strange problems here, since 2.4.12 (2.4.10 was ok, I
> never tried .11)
2.4.10 was the first kernel that broke for me.

> I've got seveal processes hanging in "D" state, especially devfsd. I
> think something with devfs and/or devfsd is broken here. If I kill
> devfsd before, the problem does not arise (but I need devfsd :-)
I've had this problem as well - it seems there's a deadlock in devfs.
I have sent a mail to Richard Gooch about this some days ago, but he
hasn't responded yet.
I will resend my bug report to the list then.

> Now, It gets even more strange: The problem does only exist if I
> deactivate ACPI! I tried with a ACPI enabled kernel with the command
> line "acpi=off", I tried on a machine which is too old for ACPI, and I
> even compiled a kernel without ACPI at all. Everywhere the same problem.
> When I boot with activated ACPI, there's no problem.
I don't know about this.

> Any hints? If someone could tell me what I should try or which debug
> info could be useful, please let me know!
>
> TIA, Michael
>


--
Johannes Kloos
"Walk a mile on these paws and call me a liar."
-- Gaspode the wonder dog (Terry Pratchett, Moving Pictures)
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:11    [W:0.038 / U:11.236 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site