lkml.org 
[lkml]   [2001]   [Oct]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectstrange hangs with kernel 2.4.12 (and 13)
Hi there,

I've got some strange problems here, since 2.4.12 (2.4.10 was ok, I
never tried .11)

The System boots fine, I can login on a text console, but when I log out
again, the system partly gets unusable. The load rises, and the text
console where I logout hangs.

I've got seveal processes hanging in "D" state, especially devfsd. I
think something with devfs and/or devfsd is broken here. If I kill
devfsd before, the problem does not arise (but I need devfsd :-)

Now, It gets even more strange: The problem does only exist if I
deactivate ACPI! I tried with a ACPI enabled kernel with the command
line "acpi=off", I tried on a machine which is too old for ACPI, and I
even compiled a kernel without ACPI at all. Everywhere the same problem.
When I boot with activated ACPI, there's no problem.

I don't understand what's happening here. I tried to debug a bit, but
couldn't find something sense- or useful.


Any hints? If someone could tell me what I should try or which debug
info could be useful, please let me know!

TIA, Michael

--
netWorks Vox: +43 316 698260
Michael Reinelt Fax: +43 316 692343
Geisslergasse 4 GSM: +43 676 3079941
A-8045 Graz, Austria e-mail: reinelt@eunet.at
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:11    [W:0.068 / U:1.056 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site