lkml.org 
[lkml]   [2001]   [Oct]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectmodprobe problem with block-major-11
If there is a better list for this, let me know and I'll take the question
there.

I have a new CDRW I've been trying to get working for a couple of months
now. Working with autoloading the modules anyway.

I've tried following the CD-Writing HOWTO for setting up modules.conf with
no luck.

Currently my modules.conf has:
options ide-cd ignore=hdc # tell the ide-cd module to ignore h
alias block-major-11 sr_mod # load sr_mod upon access of scd0
pre-install sg modprobe ide-scsi # load ide-scsi before sg
pre-install sr_mod modprobe ide-scsi # load ide-scsi before sr_mod
pre-install ide-scsi modprobe ide-cd # load ide-cd before ide-scsi

And lilo.conf has:
append="hdc=scsi"

Of course, also tried hdc=ide-scsi with same results.

Now, if I try something like ``head /dev/scd0'' I see the following in
dmesg:
SCSI subsystem driver Revision: 1.00
Uniform CD-ROM driver unloaded

And the following in /var/log/ksymoops:
20011024 214049 start /sbin/modprobe -s -k -- block-major-11 safemode=1
20011024 214050 probe ended

Now, if I take the command from that:
/sbin/modprobe -s -k -- block-major-11

I get the following:
thune:~# /sbin/modprobe -s -k -- block-major-11
Warning: loading /lib/modules/2.4.12/kernel/drivers/cdrom/cdrom.o will
taint the kernel: no license
Warning: loading /lib/modules/2.4.12/kernel/drivers/ide/ide-cd.o will taint the
kernel: no license
ide-cd: ignoring drive hdc
Vendor: PHILIPS Model: PCRW804 Rev: 2,1
Type: CD-ROM ANSI SCSI revision: 02
Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
sr0: scsi3-mmc drive: 32x/32x writer cd/rw xa/form2 cdda tray

ksymoops has:
20011024 214923 start /sbin/modprobe -s -k -- block-major-11 safemode=0
20011024 214923 start modprobe ide-scsi safemode=0
20011024 214923 start modprobe ide-cd safemode=0
20011024 214924 probe ended
20011024 214924 probe ended
20011024 214924 probe ended

And dmesg shows:
CSI subsystem driver Revision: 1.00
ide-cd: ignoring drive hdc
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
Vendor: PHILIPS Model: PCRW804 Rev: 2,1
Type: CD-ROM ANSI SCSI revision: 02
Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
sr0: scsi3-mmc drive: 32x/32x writer cd/rw xa/form2 cdda tray
Uniform CD-ROM driver Revision: 3.12


So, it appears to me that the autoloading should work. But it's not.

What am I missing?

Help appreciated,
mrc
--
Mike Castle dalgoda@ix.netcom.com www.netcom.com/~dalgoda/
We are all of us living in the shadow of Manhattan. -- Watchmen
fatal ("You are in a maze of twisty compiler features, all different"); -- gcc
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:10    [W:0.080 / U:0.484 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site